Mist king zip drip if you have one that works please help

Multivitamins

Chameleon Enthusiast
Update I believe it's a matter of the t unit missing I used it to creat the loop fr mister to zip drip but was not given another one to facilitate the closed loop to the pump and end of zip drip I think getting another one of those will resolve my issue. Wish they included that when I bought the kit

Been having issues with zip drip either dripping or giving a continuous flow of water any experience with them please shoot me a pm or comment thanks in advance
 
Last edited:

Ruthless

Avid Member
I have a Zip drip without any issues maybe you have it setup wrong can you post a pic of it and maybe I can help you trouble shoot.
 

Multivitamins

Chameleon Enthusiast
I have a Zip drip without any issues maybe you have it setup wrong can you post a pic of it and maybe I can help you trouble shoot.

May I ask for a photo of how your zip drip set up is attached @Ruthless as I now know that mine is / was wrong.

I've swapped back to the basic set up for now since I know it works and I can deal with some drips the next few days until they can send out the missing part.
After troubleshooting I realized they only gave me one of the t shaped valve adapters that are needed to create the loop back to the zip drip and not a second one to connect to the pump / reservoir from the end of the zip drip

The PDF of the manual gives very minimal instructions pretty much leaving it at use the T shaped connection to loop tubing from mister back to zip drip.

I currently swapped to how it was prior to attempting the zip drip set up and am using an L shaped adapter to connect my pump to the misters

I've attached a photo of the part that I believe I need two of in order to make it work properly

The second photo is what was provided with the zip drip upgrade

Thank you for your reply
 

Attachments

  • 15591944244887635493140476412240.jpg
    15591944244887635493140476412240.jpg
    257.5 KB · Views: 36
  • 155919461560336461318714942771.jpg
    155919461560336461318714942771.jpg
    114.1 KB · Views: 33

Ruthless

Avid Member
Here you go the tube on the left is leading to the misting nozzles and the one on the right to the water reservoir you will need another T coming from your mist nozzle to the bottom of the Zip drip. Your Mistking package should have a T fitting as part of the package for your nozzles if not I can see how come it wouldn’t work for you.
233928
 
Last edited:
Top Bottom