Please help! Mistking issue

Daesie11

Chameleon Enthusiast
My Mistking is suddenly not working. I turn it on and I can hear and feel the pump running, but no water is being pulled through. I put my hand against the nozzle that pulls the water in and I am feeling no suction at all. Nothing has changed between now and yesterday when I last saw it working (I've been at work all day today, so I have no idea if it worked at all today or not). I'm freaking out because I am supposed to go pick up my new cham TOMORROW :(:(
 

Beman

Chameleon Enthusiast
My Mistking is suddenly not working. I turn it on and I can hear and feel the pump running, but no water is being pulled through. I put my hand against the nozzle that pulls the water in and I am feeling no suction at all. Nothing has changed between now and yesterday when I last saw it working (I've been at work all day today, so I have no idea if it worked at all today or not). I'm freaking out because I am supposed to go pick up my new cham TOMORROW :(:(
Did you disconnect the tube from the nozzle head and prime the pump? You have to run it unhooked sometimes to get it to start up again. Pressing the up arrow will get it to run. Keep a cup handle because it will start gushing out the tube all the sudden. Every time I forget to add more water I have to prime it again as well lol. Has only happened twice now though.
 

Daesie11

Chameleon Enthusiast
So I got it to run but it keeps puttering in and out. I figured it had to do with the motor being above the reservoir, but just that alone doesnt seem to be fixing it. It seems like whenever I tilt it in a certain way it starts to go again??? Is there some specific sort of way it is supposed to be stored that I missed in the manual??
 

Daesie11

Chameleon Enthusiast
Did you disconnect the tube from the nozzle head and prime the pump? You have to run it unhooked sometimes to get it to start up again. Pressing the up arrow will get it to run. Keep a cup handle because it will start gushing out the tube all the sudden. Every time I forget to add more water I have to prime it again as well lol. Has only happened twice now though.
I didnt even run out of water though, my reservoir is half full still??
 

Beman

Chameleon Enthusiast
Ok it needs to be gravity fed so all the air gets pushed out of the pump.... so water needs to sit above the pump... You need to do this and have the pump sitting on the rubber feet. I took a screw and mounted my pump through one of the rubber washers to keep it from moving and making noise.
Once you have it gravity fed then you may have to prime the pump by disconnecting the tube from the misting head and press the up arrow on the timer. It can take up to five minutes for it to push all the air out and start a heavy flow.
Your using distilled water or RO water as well right?

IMG_2587.jpg
 

Daesie11

Chameleon Enthusiast
Ok it needs to be gravity fed so all the air gets pushed out of the pump.... so water needs to sit above the pump... You need to do this and have the pump sitting on the rubber feet. I took a screw and mounted my pump through one of the rubber washers to keep it from moving and making noise.
Once you have it gravity fed then you may have to prime the pump by disconnecting the tube from the misting head and press the up arrow on the timer. It can take up to five minutes for it to push all the air out and start a heavy flow.
Your using distilled water or RO water as well right?

View attachment 229445
Yes absolutely. I have 4 jugs of distilled water sitting by my cage for when my reservoir starts to get low. I used tap water in a humidifier once for personal use and learned my lesson there lol.
I changed the location of my motor and it immediately started working. Thank you so much! Please excuse my freak out, I have first time mom jitters! Doing some last minute tests to make sure everything is perfect
 

Beman

Chameleon Enthusiast
Yes absolutely. I have 4 jugs of distilled water sitting by my cage for when my reservoir starts to get low. I used tap water in a humidifier once for personal use and learned my lesson there lol.
I changed the location of my motor and it immediately started working. Thank you so much! Please excuse my freak out, I have first time mom jitters! Doing some last minute tests to make sure everything is perfect
Lol I have been there! I have an old thread of my own freaking about the pump not working and pleading for help! Your fine hun!
 

CamoChameleonsHuman

Chameleon Enthusiast
Yes absolutely. I have 4 jugs of distilled water sitting by my cage for when my reservoir starts to get low. I used tap water in a humidifier once for personal use and learned my lesson there lol.
I changed the location of my motor and it immediately started working. Thank you so much! Please excuse my freak out, I have first time mom jitters! Doing some last minute tests to make sure everything is perfect
I go through about a gallon or slightly more in distilled water a day. Next upgrade RO system.
 
Top Bottom