Female Cham not laying eggs

ERKleRose

Chameleon Enthusiast
Thank you for all the info. I've gotten a T8 light with a 5.0 UVB and I also paired it with a 75watt basking light. I ordered roaches that should be coming in on Saturday. Until then I'm giving her crickets every other day dusted with Reptivite calcium with D3. The pot of sand is 10" w and 8" h. I won't handle her as much. How long do you think until she lays eggs with these changes?
Can you return the 5.0 bulb? You need either a T8 Zoo Med ReptiSun 10.0 or Arcadia 12% bulb to provide enough UVB from a T8 fixture (the bulb 5" from her basking branch). Reptivite With D3 is a multivitamin and D3 supplement (use only once every two weeks). You need to get a phosphorus-free calcium without D3 (like Zoo Med ReptiCalcium Without D3 or Repashy SuperCal NoD) to use at all other feedings, as well.
 

lizardgirll

New Member
Can you return the 5.0 bulb? You need either a T8 Zoo Med ReptiSun 10.0 or Arcadia 12% bulb to provide enough UVB from a T8 fixture (the bulb 5" from her basking branch). Reptivite With D3 is a multivitamin and D3 supplement (use only once every two weeks). You need to get a phosphorus-free calcium without D3 (like Zoo Med ReptiCalcium Without D3 or Repashy SuperCal NoD) to use at all other feedings, as well.
I can return it. They only had a 5.0 bulb at petsmart so I just got what I could, but I will order a 10.0 bulb but use the 5.0 until it gets here. I usually use phosphorus free calcium without D3 in her feedings anyway, and I will keep in mind to only use D3 once every 2 weeks. Thanks!
 

lizardgirll

New Member
Hi everyone! I'm new to the site so I'm still trying to figure out how all this works. Anyway, I have about an 8 month old female veiled chameleon named Andi. She's very energetic and friendly and hates being inside her cage. I took her to the vet in July for a checkup and they told me that she should be laying eggs (unfertilized) in about 30-40 days. I put a little container of moss in there (per the vet's recommendation) but no eggs. After reading some of these posts, I realized she needs something better so I put a pot of sand in her tank. She still hasn't laid any eggs. She's very swollen and has been for a few months. The orange/yellow spots showed up in mid to late June. I'm not sure what to do. For lighting, I use a UVB bulb and a blue light bulb. I recently added a spot basking light because it wasn't warm enough. I spray her cage with water multiple times a day and her diet usually consists of vegetables and mealworms, sometimes crickets. Any advice/suggestions would be greatly appreciated! Attached are some pics of her.

View attachment 309444 View attachment 309445
Hey everyone. I wanted to do a quick update on Andi. I took her to the vet a couple weeks ago to get things checked out and it turns out she does not have eggs! The vet did an X-ray and he found no eggs but did see that she had started eating the sand I had put in her cage for the "eggs" (she's fine). The vet said she is beautiful and one of best looking chameleons he's seen in a while and gave me a pat on the back for doing a good job. She's healthy and happy, I'm a proud mama. Here are a couple pictures of her when she was ready to go to sleep :)
 

Attachments

  • IMG_8975.jpg
    IMG_8975.jpg
    175.2 KB · Views: 18
  • IMG_8977.jpg
    IMG_8977.jpg
    174.9 KB · Views: 19

kinyonga

Chameleon Queen
Wow....giid that she has no eggs but I hope the sand isn't causing her problems. Did the vet thing it would pass through her ok?

What brand (manufacturer's name)
of sand do you use?
 
Top Bottom