Tiny Bit of Blood in Zelda's Poop/Urate???

Breezy9

New Member
I've been noticing the past few days that Zelda has been taking an extra long time to poop. She has had about 3-4 waxworms in the past week but not all at once. I know they are high in fat and should only been given as treats. They are her absolute favorite and she would eat them all day every day if I let her. lol.

Okay, so today I noticed a TINY bit of blood in her poop. I would like to know what you all think? She's 6 months old now and hanging out near the bottom of the cage a lot and I know that's a sign that they need to lay. So I researched (again) and set up a laying bin. So far nothing but is the blood a sign of her about to lay? Infertile eggs of course.

Here is a pic.
photo (3).jpg
 

Breezy9

New Member
She's been acting normal, healthy, and eating on her own for a couple weeks now. I'm just worried about her being able to endure the egg laying process after all she's been through lately...
 

Breezy9

New Member
Now the poop is dry and looks totally normal. If I didn't see her actually pooping I never would have noticed. So weird! But I would still like any thoughts please. Thanks!
 

Breezy9

New Member
A fecal was done when we were at the vet for her RI. It was negative. I forgot to add that. Thanks, though!
 

Breezy9

New Member
Poop has been normal since I posted. Must've been the waxworms. I will cut back on them. I was only giving 3-4 a week. Zelda LOVES them so much! I'm getting some silks today so I'm sure she won't mind TOO much. Lol.
 
Top Bottom