brand new mistking not working

scbikes45

New Member
hey guys and gals, i just finished installing my brand new mist king setup, its the value set, with 3 extra nozzles, totaling 4 nozzles. Ive plumed everything got the nozzles installed, bucket has the bulk head i plugged the timer in and plugged the pump in and it does nothing.... any ideas ? anyone had a bad pump straight out of the box? or maybe its a bad power supply wire with the black box on it? i felt the pump with my hands and its not doing anything, Ive tried different plugs in my room and nothing..... its pretty disappointing to say the least, Ive waited for a week and a half for it to get here and it doesn't work, unless i am a complete idiot and missed something blatantly obvious.... does anyone have any idea whats going on? any words of advice?
 
You have plugged the pump alone, directly into a wall outlet? If that still doesn't work, you might want to contact the vendor...

Sorry to hear. :eek:
 

scbikes45

New Member
i haven't tried direct to a wall, but to a power strip that i know works and still nothing.... ill try the wall tomorrow
 
i haven't tried direct to a wall, but to a power strip that i know works and still nothing.... ill try the wall tomorrow

I mean without the pump being plugged into the timer... if you know the wall strip works... and you didn't have the timer connected, there is most likely an issue.
 

hondataeg6

New Member
Do the misting pumps have to primed? Or are they self priming pumps? Looking to get one, still haven't decided between mistking or aquazamp...
 

Dawniegirl

New Member
Do you have the wiring right? We had ours reversed & mist king wouldn't go on. I reverse what was plugged into what & it immediately worked. Marty from Mist King is on forum... send him a pm if you can't figure it out & I'm sure he can walk you though it.
 

Kerrek

Member
Double check the connection between the pump and power source. I had problems with the connection on mine had to "wiggle" it to get it to work. After I got a good connection it's worked fine ever since.
 

Marty

MistKing
Site Sponsor
Boy, hard to keep up with you :) Got the email, facebook and found it here. Check your email, no worries.

Marty
 

Action Jackson

Chameleon Enthusiast
I also had a problem with the plug from the power supply to the pump. One of the prongs popped out of the plug. My Mistking is down right now due to a blown fuse in the power supply.:(
 

krknieriem

New Member
honda I found when I hooked up mine using a 5 gallon bucket as a reservoir that the pump primed itself when the pump location was less than 6 inches off the floor with the bucket sitting on the floor
 

Marty

MistKing
Site Sponsor
When the pumps ship these are totally empty. Attaching it to hose with checkvalved nozzles at the end will make priming very hard. put pump on the floor fill up the reservoir, unplug the tubing from the nozzle and just run it for a minute or two until water comes out...you'll see water coming out in squirts and it will bubble...once all the air comes out and the pump is pumping a somewhat steady stream you can plug it into the nozzle. After that you should be all set.
 

scbikes45

New Member
This was the problem, Marty called me with morning and I wiggled some wires and it now works!! +1 for customer service!!
 
Top Bottom